PHP is one of the most widely used class-based programming languages. It is exceptionally popular as it is free software, which you can use to set up responsive sites such as community web portals, online shopping portals or e-learning websites instead of static HTML websites. A PHP module should be activated on the server where a PHP-driven website is hosted so that its PHP code can be interpreted. Since there are no license fees for this type of module and the language provides infinite possibilities for the web-based applications that you create, there are hundreds of millions of PHP-driven websites. In addition, there’re many open-source PHP scripts, which you can use for your sites without needing to have any coding skills. As there are a couple of versions of PHP, you need to confirm whether the exact same version that you used while building your site is activated on the server as well.

PHP 4 and PHP 5 Support in Hosting

Our hosting servers support several versions of PHP, which suggests that your sites will work flawlessly no matter if your PHP-based scripts are out of date. We accept the fact that an old website doesn’t always equal a vulnerable one as you may have implemented lots of code mods. This is why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can choose which one will be active for your account. The version can be changed with only one mouse click through your Hepsia hosting Control Panel and the new settings will be applied momentarily. If you’d like to run both older and newer scripts, there’s even an option to use a different version of PHP for each of your domain names at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated servers support multiple PHP versions, which means that you will be able to use all the web-based apps that you’ve created throughout the years. The Hepsia hosting Control Panel, which comes with each and every semi-dedicated account, will permit you to enable the version that you need with one single click of the mouse. You can select between PHP 5.5, 5.4, 5.3, 5.2 and 4. In case you wish to host multiple sites under the same account and they have distinct requirements connected with the hosting environment, you’ll be able to specify a different version for each and every one of them regardless of which version is selected for the account as a whole. That’s achievable owing to our custom-developed cloud platform, which permits us to run multiple versions of PHP at the same time. In stark contrast, the great majority of web hosts typically offer one, in rare cases – two versions.